Compiere on
Fyracle demo

Windows HOW-TO

Linux HOW-TO

The Firebird Oracle Mode / Compiere ERP+CRM Demo

The Compiere ERP+CRM system is one of the most popular packages of its kind. It has been downloaded over half a million times and is in active production use at over 50 locations. It is supported by VAR's all over the world.

The Compiere package was written for Oracle. Many users have asked for compatibility with an open-source database. All attempts failed, because the databases were just not up to the task. Except for one: Firebird. Oracle-mode Firebird (nick-named Fyracle) supports Compiere just fine.

Compiere 2.5.3a (configured for Fyracle)

To install the Compiere package, download the file and unzip it to the directory of your choice (recommended is "D:\Compiere2" on Windows or "/opt/Compiere2" on Linux). The directory contains java and xml code and is identical for both Windows and Linux. The pre-loaded database file is in the sub-directory "data".

On the configuration tab of the Compiere login dialog the location of the database can be configured. Set the database user name to "SYSDBA" and the database password to "masterkey".

More information on running, configuring and using Compiere can be found on the Compiere website. You can check the contributed HOW-TO's for Linux and Windows in the community download area for further details. The compiere source code is available as a separate download for those who want to experiment

File  Description  Version  Database import file  253a  Main application  253a  Sources  253a  Data migration tool from Oracle  1.1 

The port if Compiere 2.5.3a to Fyracle was created by Jotel. Jotel provides an alternative download location, should this site be congested. Jotel also offers support.

Fyracle (Oracle-mode Firebird)

To run Compiere you need to install the Fyracle Runtime Kit or the Fyracle Developer Kit. You can download the free runtime kit here or buy the developer kit here.


Java SDK 1.5 (needed for running Compiere)

To run Compiere you need to install the Java runtime. In order to run the Compiere server (optional) you need to install the Java SDK. Both packages can be found on the site of Sun Microsystems